【生意多】-免费发布分类信息
当前位置: 首页 » 新闻 » 教程 » 操作系统 » 正文

数据库操作出错(系统出错,数据库操作失败)

放大字体  缩小字体 发布日期:2022-07-03 20:13:45    浏览次数:11

如题, 记录一次失败解决步骤 : linux(ubuntu 18.04) 中idea操作数据库失败,报错信息:Client does not support authentication protocol requested by server; consider upgrading MySQL client. 因为我也是一个小白,其中有些概念是基于我的理解,如有错误,请指正!!!

可能原因: 权限不足

我发现我在 terminal 进入mysql的时候,每次都需要root权限.不然"Access denied for user ‘root’@‘localhost’"就算是在navicat中也是一样.普通用户根本连接不上.总是报 2002 错误.但如果我是root用户,登进去就没有一点问题,就很迷!
所以我怀疑是我的idea没有root权限导致的.毕竟我是用普通用户权限打开idea的.
附 terminal 登录mysql 方法(root 可替换成其他用户名)

?
1 via :~$ mysql -u root -p

area>via :~$ mysql -u root -parea>

大概的解决方案 创建一个普通新用户,此用户拥有增删改查所有权限,idea中使用此用户名与密码登录.可行!! 详细操作 使用root权限进入mysql

?
1
2
via :~$ sudo su
via :~$ mysql -u root -p

area>via :~$ sudo suvia :~$ mysql -u root -parea>

增加用户

?
1 CREATE USER '用户名'@'host' IDENTIFIED BY '密码';

area>CREATE USER '用户名'@'host' IDENTIFIED BY '密码';area>

授权 (我是授予所有的权限 所以是ALL 看情况修改)

?
1 GRANT ALL ON *.* TO '用户名'@'localhost';

area>GRANT ALL ON *.* TO '用户名'@'localhost';area>

刷新

?
1 flush privileges;

area>flush privileges;area>

到此这篇关于 关于linux(ubuntu 18.04) 中idea操作数据库失败的问题的文章就介绍到这了,更多相关idea操作数据库失败内容请搜索脚本之家以前的文章或继续浏览下面的相关文章

 
(文/小编)
打赏
免责声明
• 
本文为小编原创作品,作者: 小编。欢迎转载,转载请注明原文出处:https://www.31duo.com/news/show-3644706.html 。本文仅代表作者个人观点,本站未对其内容进行核实,请读者仅做参考,如若文中涉及有违公德、触犯法律的内容,一经发现,立即删除,作者需自行承担相应责任。涉及到版权或其他问题,请及时联系我们。
 

(c)2016-2019 31DUO.COM All Rights Reserved浙ICP备19001410号-4

浙ICP备19001410号-4